Armory Sync -> ApiSync

Sync Blizzards' Armory data with WoWRoster (addon depreciated no longer works see ApiSync)

Moderators: Ulminia, poetter

Armory Sync -> ApiSync

Postby Ulminia » Fri Sep 16, 2011 1:15 am

aprmorysync is now ApiSync follow my new forum for detales...
forum172.html
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Gator81 » Thu Oct 06, 2011 5:47 am

i get this
WoWRoster deprecated


You are using WoWRoster

Version: 2.1.0

To use ApiSync Version 1.0
you will at least need WoWRoster

Version 2.1.9.2340

Please update your WoWRoster

and at the bottom i get

PHP Errors

addons/ApiSync/inc/ApiSyncjob.class.php
Notice line 764: Undefined index: ApiSync_logo_show
Notice line 766: Undefined index: ApiSync_logo_pos_left
Notice line 767: Undefined index: ApiSync_logo_pos_top
Notice line 768: Undefined index: ApiSync_logo_size

i understand this is beta but i cannot get the svn version of roster to let me test
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Ulminia » Thu Oct 06, 2011 9:50 pm

yes but api sync will ONLY work with the svn roster 2.2 (furture ver) because of the api files that are needed it wont work with roster 2.1.0 because of this ... try and check out the roster svn ither on google code or using your svn client then this will work...
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Gator81 » Sun Oct 09, 2011 2:45 pm

I have went to the link in google code that you have but i can only guess i dont have access to see the svn as I couldnt find it anywhere. :(

I followed up again just to make sure, i went to the link on the main page, there is a spot that says to download the latest version but it just takes me to the link to get the latest release not the .svn
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby zanix » Sun Oct 09, 2011 10:56 pm

This is a better link on getting access
http://code.google.com/p/wowroster/source/checkout

Use this command to anonymously check out the latest project source code:

Code: Select all
# Non-members may check out a read-only working copy anonymously over HTTP.
svn checkout http://wowroster.googlecode.com/svn/trunk/ wowroster-read-only


Basically you need a SVN client, I would suggest TortoiseSVN
This might help you out as well Checking Out A Working Copy
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: Armory Sync -> ApiSync

Postby Gator81 » Mon Oct 10, 2011 1:22 am

I am sorry i didnt do more research, i remember having to do this in the past and it just didnt occur to me that was what i forgot. I was finally able to download the svn and will be working on setting it up and testing as soon as i can...thank you for the nudge :)
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Gator81 » Wed Oct 12, 2011 6:07 am

ok, i uploaded the svn and overwrote what i had, after i did and i loaded the roster it asked if i wanted to update and i said yes and it said update complete

when i do the sync for guild and click on start i get a page with this error

Fatal error: Wrong parameters for Exception([string $exception [, long $code ]]) in /home/content/g/a/t/gator81/html/sites/gswamp/roster/lib/api/tools/ResourceException.php on line 23

on the page to do the start i see the php errors which are :

PHP Errors

addons/ApiSync/inc/ApiSyncjob.class.php
Notice line 764: Undefined index: ApiSync_logo_show
Notice line 766: Undefined index: ApiSync_logo_pos_left
Notice line 767: Undefined index: ApiSync_logo_pos_top
Notice line 768: Undefined index: ApiSync_logo_size
lib/aprint.php
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class
Notice line 268: Undefined index: class

when i goto the char list, again the debug says everything is ok, when i click on start, it starts to update and then gives this error:

Fatal error: Wrong parameters for Exception([string $exception [, long $code ]]) in /home/content/g/a/t/gator81/html/sites/gswamp/roster/lib/api/tools/ResourceException.php on line 23

i also wanted to add my info, i figure using the {code} feature so it will not show to big

Code: Select all

Basic Server Info

OS
Linux
Server Software
Apache
MySQL Version
5.0.91-log
PHP Settings
PHP Version
5.2.14
PHP API Type
cgi-fcgi
safe_mode
Off
open_basedir
Off
allow_url_fopen
On
file_uploads
On
upload_max_filesize
8M
GD Support
GD Status
On
GD Version
bundled (2.0.34 compatible)
FreeType Support
Yes
FreeType Linkage
with freetype
T1Lib Support
No
GIF Read Support
Yes
GIF Create Support
Yes
JPG Support
Yes
PNG Support
Yes
WBMP Support
Yes
XPM Support
No
XBM Support
Yes
JIS-mapped Japanese Font Support
No
Config Values
Show All Config Data
version
2.1.9.2369
db_version
6
db_prefix
roster_
debug_mode
On
roster_lang
enUS
img_url
img/
interface_url
http://www.wowroster.net/
img_suffix
png
use_update_triggers
On
rs_display
full
 
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Ulminia » Wed Oct 12, 2011 1:56 pm

5.2.14 ... >< .. the api is coded for php 5.3.... um....
try commenting out
"parent::__construct($message, $code, $previous);"

in roster/lib/api/tools/ResourceException.php on line 23
should help fix the error .. also you need to have curl enabled... api sync should check for this ....
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Gator81 » Wed Oct 12, 2011 10:01 pm

I tried to comment out that line and it didnt work, it gave another fatal error that was about greater then the one line.

as for the curl, i am not sure where i would see that.

I turned on debug and it says that everything is ok an i get the box of php errors at the bottom like i already posted.

I did notice in the admin setup for the selection to use Ajax that the buttons were off/off and not on/off like the others.
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Ulminia » Wed Oct 12, 2011 10:11 pm

yes im removing ajax support
ial do some work tonight and post an updated file in the downloads i hope to solve some of the issues
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Ulminia » Wed Oct 12, 2011 11:25 pm

ok i updated the roster svn with the api changes
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Gator81 » Thu Oct 13, 2011 6:22 am

I hope i am of some help with the testing :/

i uploaded the changes you made and when i did the update for the guild it seem to load and then everything refreshed and it said finished, in the line under where it says guild info there was the nothing under it but the error symbol.
at the top i did get a curl error:
Curl has Failed!

The selected api action is not allowed6
Couldn't resolve host '.battle.net'

as i looked at the debug info it looked like it pulled the message of the day, the names and levels of groups and some other things, an all the debug info seem to say ok.

when i did this for the members, it showed all the members, and started at the first one, timed out with the curl error and went to the second. Before it would just error and stop.

could there be a setting that i need to look for or something else to verify why it couldnt resolve the host?
Anything else i need to do to verify that curl is working like it should?

thanks
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Ulminia » Thu Oct 13, 2011 11:18 am

rostercp->Update Access-> SEt the **.battle.net address dropdown the config var dosent have a name for some reason *shrugs* but that needs to be set for it to work thats your issue....
"Couldn't resolve host '.battle.net' "
is a incomplete api address.. it has to be us/eu/kr/tw thats your whole problem
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Armory Sync -> ApiSync

Postby Gator81 » Thu Oct 13, 2011 7:23 pm

i logged into my roster cp with admin, went to main settings and then selected update access, under th api key lines (no key for private or public) is a blank line with a pull down that has us.battle.net selected

i went through the rest of the cp and couldnt find any place else that wanted that info.

I may just have to remove the entire roster, delete the database, and start everything from fresh install of everything and see if that makes a difference. This was the release version that i had used profiler to update the guild and some of my toons, that info was working with no problems, it was i couldnt use the armory. I wanted to test the Armory Sync and I seem to be the only one having problems or at least posting them.
Gator81
WR.net Journeyman
WR.net Journeyman
 
Posts: 115
Joined: Fri Jun 01, 2007 4:44 am

Re: Armory Sync -> ApiSync

Postby Ulminia » Fri Oct 14, 2011 5:30 am

with the dropdown check your database in _config and make sure api_url_region isset us for us.battle.net eu for eu.battle.net sometimes selecting one of the others then the proper one will input the value in to the database
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Next

Return to ArmorySync - Depreciated

Who is online

Users browsing this forum: No registered users and 0 guests

cron