ItemStatsDF [v2.0beta]

This mod will allow any part of DragonFly that uses bbcode to be able to use ItemStats
No longer maintained

ItemStatsDF [v2.0beta]

Postby robojerk » Thu Jun 14, 2007 3:27 pm

If you can't see the upgarde link under the modules screen click on Edit, there will be a a upgrade link there right next to a linkto back up the database.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby Pugro » Thu Jun 14, 2007 5:05 pm

Cheers for the location of that link robojerk!

I'm getting another small issue though, my icons for itemico tags are not working, as an example of a mooncloth tag the image source is:

Code: Select all
http://www.wowhead.com/images/icons/medium/INV_Fabric_MoonRag_01.jpg


Any ideas?
--------------------------------
Pugro_
Ice and Trinity Guilds, Nordrassil, EU PvE
www.iceguild.org.uk, www.trinityguild.net
Image
Pugro
WR.net Journeyman
WR.net Journeyman
 
Posts: 79
Joined: Fri Jul 07, 2006 2:14 pm
Location: London, UK

Re: ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 12:34 am

Pugro wrote:Cheers for the location of that link robojerk!

I'm getting another small issue though, my icons for itemico tags are not working, as an example of a mooncloth tag the image source is:

Code: Select all
http://www.wowhead.com/images/icons/medium/INV_Fabric_MoonRag_01.jpg


Any ideas?


I noticed that last night but when I went to WoWHead it was undergoing some maintenance so I figured that was what was causing it.. I'll look into it.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 4:33 am

Other people are having icon issues too all of a sudden. I think WoWHead didn't like people stealing their icons.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby Pugro » Fri Jun 15, 2007 5:26 am

Manually going to the link redirects to the main page...so they may be getting upset...

Only issue is I seem to be unable to change the source of the icons..it always to grab them from WoWHead :(
--------------------------------
Pugro_
Ice and Trinity Guilds, Nordrassil, EU PvE
www.iceguild.org.uk, www.trinityguild.net
Image
Pugro
WR.net Journeyman
WR.net Journeyman
 
Posts: 79
Joined: Fri Jul 07, 2006 2:14 pm
Location: London, UK

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 5:51 am

You're kind of forced to use the wowhead images..

http://forums.eqdkp.com/index.php?showtopic=9342
fenuz wrote:wowhead uses different filenames for its icons than thottbot and allakhazam. Therefor it will be hard to mix the tooltips using the same icon store location.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby Pugro » Fri Jun 15, 2007 6:28 am

Bah, cheers for that, I'll roll back for now.
--------------------------------
Pugro_
Ice and Trinity Guilds, Nordrassil, EU PvE
www.iceguild.org.uk, www.trinityguild.net
Image
Pugro
WR.net Journeyman
WR.net Journeyman
 
Posts: 79
Joined: Fri Jul 07, 2006 2:14 pm
Location: London, UK

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 6:34 am

I know, it's kind of lame.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 7:04 am

I'll look into maybe making it so WoWHead icons have their own store.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 10:44 am

WoWHead icons are all named in lower case.

WoWHead name inv_jewelry_ring_51naxxramas
All other name INV_Jewelry_Ring_51Naxxramas

WoWHead icons are jpg
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

ItemStatsDF [v2.0beta]

Postby zanix » Fri Jun 15, 2007 12:48 pm

That's how our icons will be named in the next interface image pack for Roster 1.8

Also Robo, would you mind if I update itemstatsdf in the downloads section with your download?
And also, would you like to be able to update the download there as well?
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

ItemStatsDF [v2.0beta]

Postby robojerk » Fri Jun 15, 2007 3:27 pm

Let me see if I can fix a few things first before this gets put into the main spotlight.

If the next version of Roster is going to use lowercase for icon names I'll see what I can do to add support for that if/when using a local icons. If using remote icons from Allakhazam or Thott I'll try to use the conventional naming they use.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: ItemStatsDF [v2.0beta]

Postby Galedon » Thu Jul 05, 2007 2:26 pm

Hey
I have a big problem with german word´s

when i take Zauberfeuergürtel - itemstats doesn´t find it

the search is item_stats&file=updateitem&item=Zauberfeuerg%25C3%25BCrtel

but correct is Zauberfeuerg%FCrtel

You see the different!

The can itemstats find the item :)

but in the tooltip all ü -ö - ä change to ?

can you make a fix for german people ?

great
Galedon
WR.net Apprentice
WR.net Apprentice
 
Posts: 9
Joined: Wed Aug 23, 2006 2:44 pm

ItemStatsDF [v2.0beta]

Postby zanix » Fri Jul 06, 2007 12:09 am

That's one of the reasons that I released this as 2.0beta
I should have stated but this is one of the current bugs that I have yet to figure out
Read the Forum Rules, the WiKi, and Search before posting!
WoWRoster v2.1 - SigGen v0.3.3.523 - WoWRosterDF
User avatar
zanix
Admin
Admin
WoWRoster.net Dev Team
WoWRoster.net Dev Team
UA/UU Developer
UA/UU Developer
 
Posts: 5543
Joined: Mon Jul 03, 2006 8:29 am
Location: Idaho Falls, Idaho
Realm: Doomhammer (PvE) - US

Re: ItemStatsDF [v2.0beta]

Postby poetter » Mon Jul 09, 2007 12:13 am

Hi, i think i fixed the issue with german umlauts:

itemstat.php

change
Code: Select all
        if ($type == 'item')
        {
            
// Initialize the html.
            
$item_html '[' $item_name ']'

with
Code: Select all
        if ($type == 'item')
        {
            
// Initialize the html.
            
$item_html '[' utf8_encode($item_name) . ']'


and

change
Code: Select all
    function getItemHtml($name$update false)
    {
        
$html $this->item_cache->getItemHtml($name);

 


with
Code: Select all
    function getItemHtml($name$update false)
    {
        
$html utf8_encode($this->item_cache->getItemHtml($name));

 


generic_itemstats.php

change
Code: Select all
        // Grab the item name.
     
$item_name $match[3];
        
$icon_lsize $match[2];
        
$item_type $match[1];
 


with
Code: Select all
        // Grab the item name.
     
$item_name utf8_decode($match[3]);
        
$icon_lsize $match[2];
        
$item_type $match[1];
 
User avatar
poetter
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 462
Joined: Sat Jun 30, 2007 9:41 pm
Location: Germany/Hamburg

PreviousNext

Return to ItemStatsDF

Who is online

Users browsing this forum: No registered users and 0 guests