Guild recruitment block and Application modules

phpNuke integration forum

Guild recruitment block and Application modules

Postby Ymryl » Sun Mar 11, 2007 5:14 pm

Blank? That is interesting. I would at least expect an error message of some kind. I notice you are using autotheme, perhaps that has something to do with it? I would take a look at the top of one of the index.php for one of the modules that does work, perhaps you need to modify the first few lines that allow access.
User avatar
Ymryl
WR.net Apprentice
WR.net Apprentice
 
Posts: 38
Joined: Mon Jul 17, 2006 11:45 pm
Location: RI, USA

Re: Guild recruitment block and Application modules

Postby Ghostmaster » Mon Mar 12, 2007 12:42 pm

morill wrote:
Ymryl wrote:
Ghostmaster wrote:Wish list:
TBC Attunements
Ability to post application as an forum post instead of email


Anaxent is currently working on moving the configuration settings into the admin module and posting to the forum rather than email for Dragonfly.


Any news about this?


The TBC key attunement is implemented, and for the forumpart, see Razac's version

/Ghostmaster
Ghostmaster
WR.net Apprentice
WR.net Apprentice
 
Posts: 23
Joined: Sun Jul 30, 2006 3:54 am

Re: Guild recruitment block and Application modules

Postby Ghostmaster » Mon Mar 12, 2007 12:52 pm

Hashberrie wrote:I followed the installation instructions and when I go to the module or the admin pages, all I have is a blank page. Is there something obvious I'm doing wrong? I'd really love to get this working!

I'm running PhpNuke 7.9. My site is http://www.gamenoir.com (module is admin only, due to the blank page currently). If anyone can help I'd appreciate it!


Try to turn on debug mode on your site at tjeck the warnings/errors, this can mabye give you a clue what the problem is.

/Ghostmaster

PS. After debugging, turn off debug mode again.
Ghostmaster
WR.net Apprentice
WR.net Apprentice
 
Posts: 23
Joined: Sun Jul 30, 2006 3:54 am

Guild recruitment block and Application modules

Postby BoriTz » Wed Mar 14, 2007 7:48 am

Hello Ymryl

I took a look on your site and i would like to ask you some questions.I really like it. It would be nice if you contact me by e-mail.I will send my e-mail on PM to you.
BoriTz
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Jan 18, 2007 12:26 pm

Re: Guild recruitment block and Application modules

Postby gnormin » Sun Mar 18, 2007 5:09 pm

I had it loading up blank defaults for the status and for the class values. I changed 2 things and now it works perfect. first part I changed was in the readme file it says to use http://www.yoursite.com/modules.php?nam ... ecruitment
however, the file it refers to has a different name. So I used this instead
http://www.yoursite.com/modules.php?nam ... l_MYSQL_db

The second thing I had to change was in the DB the table that installed once the querry was run was "recruitment2", If you remove the 2 from the end of the table name it works perfectly.

Its likely that somewhere allong the lines I messed up something but just incase I figured I would mention it here if others have this issue.
gnormin
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Mon Jan 01, 2007 3:50 pm

Guild recruitment block and Application modules

Postby BoriTz » Wed Mar 28, 2007 12:33 pm

Hello

I installed the recruitment block but when someone who is not registered to the portal tries to make a application they get a message that the module is not active even thou i have activated it for all visitors. Can you please help me with this?


BoriTz
Last edited by BoriTz on Fri Mar 30, 2007 1:26 pm, edited 1 time in total.
BoriTz
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Jan 18, 2007 12:26 pm

Re: Guild recruitment block and Application modules

Postby Bacchatus » Sat Mar 31, 2007 8:56 pm

It just doesn't work for me. Everything displays fine, everything seems to work okay. But it never sends the email. I've edited the config file, but no go. It may be a security issue, since I've gone back to Futurenuke. But if it is, I can't find it.
Bacchatus
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Thu Dec 14, 2006 10:55 am

Re: Guild recruitment block and Application modules

Postby Bacchatus » Tue Apr 03, 2007 4:08 am

I tried some other PHP mailing things and none of those work either. I wonder if it has something to do with my PHP version? (4.3.11)
Bacchatus
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Thu Dec 14, 2006 10:55 am

Re: Guild recruitment block and Application modules

Postby Weeladdie » Fri Apr 06, 2007 2:23 am

Razac wrote:I took this little addon one or two or three steps further.

Since I didnt want an email to be sent out and it seemed not right to send all applications to one personand not the class leaders I decided to create a Database table and have all the applications added there.

I have also greatly modified the Application form to better portray the new TBC content.

View the application here. Dawn of Wolves Guild Application

I then added some security to the new admin page that displays the applications so that only members of the Officer group on my site can view them.

They will see a list of applicant and each applicant can be viewed or deleted. It will also display text "NEW" if the application is new that day. When viewed the application will show again but all the responses will be in red text.

here is what is seen in admin
Admin screen 1

Admin Screen 2


Razac....any chance of posting up your code changes as I will defintely find it useful...although I note that you state on your site you are having problems with the form atm.
User avatar
Weeladdie
WR.net Apprentice
WR.net Apprentice
 
Posts: 12
Joined: Tue Jul 04, 2006 1:48 pm

Re: Guild recruitment block and Application modules

Postby Bacchatus » Fri Apr 06, 2007 2:29 am

Fixed mine.
Bacchatus
WR.net Apprentice
WR.net Apprentice
 
Posts: 3
Joined: Thu Dec 14, 2006 10:55 am

Re: Guild recruitment block and Application modules

Postby Fanatic » Thu Apr 12, 2007 2:58 am

I have my own application made on my website is there any way I can still use the recruitment block but have it linked to my current application?

Also I need a little help getting this block to work, all of the files are in the correct folders and edited as needed, can someone write a quick instruction on how to activate the mod and get it placed into a block on my page?

Very much Appreciated!
Fanatic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Apr 12, 2007 2:55 am

Re: Guild recruitment block and Application modules

Postby Fanatic » Thu Apr 12, 2007 10:07 am

Anyone? a little help on this?
Fanatic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Apr 12, 2007 2:55 am

Re: Guild recruitment block and Application modules

Postby Ymryl » Thu Apr 12, 2007 10:09 pm

Fanatic wrote:I have my own application made on my website is there any way I can still use the recruitment block but have it linked to my current application?


You can change the link destination at the top of the block-Recruitment.php file:

Code: Select all
// Set this to the path to your recruitment page
$recruitment = "modules.php?name=Application";


Changing this will completely avoid the use of the actual recruitment page and application form.

Alternately, if you do wish to use the recruitment page but want the link from there to go to a different destination, you will need to modify the link destination at the bottom of the index.php file in the modules/Application/ folder:

Code: Select all
   <h3 align="center"><font color="#0000ff" size="3"><strong><a href="modules.php?name=Application&apply=true" target="_top">Click Here to Apply Now!</a></strong></font></h3>


Also I need a little help getting this block to work, all of the files are in the correct folders and edited as needed, can someone write a quick instruction on how to activate the mod and get it placed into a block on my page?

Very much Appreciated!


Place the block on your page:
1) Log into your admin panel
2) Click on the Blocks icon
3) Scroll down to the 'Add a New Block' area
4) Click the dropdown box next to 'Filename:'
5) Scroll down in the dropdown and select Recruitment
6) Set the position to the side you wish the block to appear
7) Set 'Activate?' to Yes
8) Set 'Who can view this?' to 'All Visitors'
9) Click the 'Create block' button.
Last edited by Ymryl on Thu Apr 12, 2007 10:12 pm, edited 2 times in total.
User avatar
Ymryl
WR.net Apprentice
WR.net Apprentice
 
Posts: 38
Joined: Mon Jul 17, 2006 11:45 pm
Location: RI, USA

Re: Guild recruitment block and Application modules

Postby Fanatic » Fri Apr 13, 2007 1:43 am

I think thats what I couldnt figure out, Im not getting the Recruitment selection in the block dropdown menu.

Is there anything obvious that ive done wrong to make it not show up?
Fanatic
WR.net Apprentice
WR.net Apprentice
 
Posts: 4
Joined: Thu Apr 12, 2007 2:55 am

Guild recruitment block and Application modules

Postby Ymryl » Fri Apr 13, 2007 2:10 am

It certainly should appear in the list as long as you placed the block-Recruitment.php in the correct folder (the blocks folder along with all of the other block-whatever.php files). If you did place it there you may want to open up one of the files that does appear and compare the top lines in the files. Perhaps there is something you need to change to work in the version of php-nuke that you are running.
User avatar
Ymryl
WR.net Apprentice
WR.net Apprentice
 
Posts: 38
Joined: Mon Jul 17, 2006 11:45 pm
Location: RI, USA

PreviousNext

Return to phpNuke

Who is online

Users browsing this forum: Bing [Bot] and 0 guests

cron