Guild Vault not uploading data

Requests, feedback, and general discussion about WoWRoster
DO NOT post topics about WoWRoster AddOns here!

Guild Vault not uploading data

Postby RayvenUK » Sat Nov 19, 2011 10:17 pm

I've recently updated our guild roster website.
Rather than upgrade, I decided to create a new database and delete all the original files and install the latest roster.
Everything has gone fine, uniuploader is uploading the characters okay, data is displaying okay, with the exception of the guild vault.
For some bizarre reason, only three items are showing in the guild vault. The odd thing is that these items are no longer in the vault, and nothing in all of the tabs are showing at all (the other tabs are completely empty).
I've been uploading the character profile file as the guild administrator, and as guild leader have even been viewing the guild vault and shaving the guild master's character data and the guild data.
If I check the database then all I can see is the three items, and if I check the uploaded lua file, there are no guild bank items listed at all.

Am I doing something wrong?
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby RayvenUK » Sun Nov 20, 2011 12:45 am

As a quick addition to this.
When uploading the profile data I get the error message
Could not find Guild. WoWRoster-GuildProfiler Addon not installed correctly?
I have checked and I have downloaded the latest guildprofiler (even deleted the addon and reinstalled it from scratch and deleted the wowroster.lua file as well for safe measure).
Checked the addons and it is ticked to load for all characters.
Checked the interface addons and under the wowroster profiles, guild scan options show and everything is ticked.
Type in /gp and it doesn't know the command.
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby Ulminia » Sun Nov 20, 2011 1:13 am

you have to have the cp installed as well or it will not work and you have to open your guild bank twice to scan all the items
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby RayvenUK » Mon Nov 21, 2011 8:14 pm

Aha! Thanks! Now we're getting somewhere.
It was already installed and active in the RosterCP which was why i could see it was empty.
Never spotted the scan was displaing 0 items the first time I opened the vault, and opening it a second time gave the correct count of items in each tab.
Saving and uploading the lua file now shows me all of the tabs and the money that is stashed in the vault.
However it is only showing me the contents of one of the tabs.
I have tried changing the visibility of all of the tabs to public, officer and guild; logged in as a guild member and an administrator; and even opened each tab of the guild vault individually (twice) and saved the character and guild with each tab opened, but I still only see one tab populated. It knows the name and icons associated with the tabs, but not the contents. :eek:
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby Ulminia » Tue Nov 22, 2011 12:14 am

post your update log and debug info for the guild bank update and we maybe able to see the issue .. and whats the url to your site?
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby RayvenUK » Tue Nov 22, 2011 8:18 pm

URL is

Not sure where to get the error log you are asking for.
I have cleaned out the wowroster.lua file and just logged in the guild master, scanned the vault twice, saved the character and the guild and then imported it from the roster with debug turned on. This is the info it printed out

I notice it is saying about the wowroster-guildprofiler addon not being installed, but it is present in the AddOns folder (I've even deleted it and installed it again from scratch), the Addons inside WoW is also showing it as present and enabled.

Parsing files

Parsed wowroster in 0.03 seconds


Processing Files
Could not find Guild. WoWRoster-GuildProfiler Addon not installed correctly?
Updating Guild Data for [Pagans of Dawn@EU-Arathor]

Member Log
Updated: 12
Added: 0
Removed: 0

GuildInfo

Updating Members
[ Greymouser ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Marzipan ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Blueface ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Hamrammr ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Kharaghiosis ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Bethanie ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Tomofinland ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Bleys ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Vironsusi ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Expectations ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Clonezone ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts
[ Menergy ]
Contrabution Rank Updated
memberslist - No main match - Main - No alts

Guild News Updated
CharacterInfo: 0 records without matching member records deleted
memberslist - 0 records without matching member records deleted
Vault:

No Items
No Log
No Vault Funds



Updating Character Data for [Tomofinland@EU-Arathor]

About to update player
Updating Equipment ..................
No Inventory Data
Updating Bank : Bag5 : Bag4 : Bag0 : Bag1 : Bag2 : Bag7 : Bag3 : Bag6
No New Mail
Updating Skills .....
Updating Professions : Cooking : First Aid : Alchemy
Updating Spellbook : Beast Mastery : General : Survival : Marksmanship : All - Guild Perks
Updating Glyphs .........
Updating Talents : 0-Marksmanship : 0-Beast Mastery : 0-Survival
Updating Reputation ..................................................................
Updating Currency ......
Updating Quests: 7
Updating Buffs: 7
No Companions

There was an error in addon Player Achievements in method char
Addon Messages:


InstanceKeys - Keycache cleaned - 0 gold stages activated - 1 item stages activated - 0 quest stages activated - 4 reputation stages activated - 0 skill stages activated
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby RayvenUK » Tue Nov 22, 2011 8:18 pm

RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby Ulminia » Tue Nov 22, 2011 8:54 pm

the debug info at the bottom of the page would be usefull too some of the sql queries could be bad...
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby RayvenUK » Tue Nov 22, 2011 9:18 pm

Yipe!
That's some information it spits out

Here yah go
Attachments
PHP Errors.txt
Errors generated by upload
(204.78 KiB) Downloaded 295 times
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby Ulminia » Tue Nov 22, 2011 10:33 pm

im still not seeing an error .... just achievements thats all...
the only other thing i can sujest os to upen your mysql admin and see if the vault data is in the database...
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby RayvenUK » Tue Nov 22, 2011 11:05 pm

Cracked it!
I spotted something unusual when I opened the addons setting in the game and noticed that the minimap icon was showing, but the tick box for it was turned off.
Ticked the box and it disappeared, unticked it and it appeared - it is working the wrong way round.
On a hunch I went into each character, unticked and ticked each setting in turn and saved the character again, and did the same with the guild.
Just re-uploaded the data and everything (even stuff I didn't realize was missing) has appeared.

Odd that.

Now all i have to sort out is why I get some strange long hex numbers appearing when I hover over the items :) but I can bash that one through in my own time.

Many many thanks for taking the time to look into this for me, who knows, someone else might have the same problem.

Colin
RayvenUK
WR.net Apprentice
WR.net Apprentice
 
Posts: 21
Joined: Sat Jan 30, 2010 10:56 am

Re: Guild Vault not uploading data

Postby Ulminia » Wed Nov 23, 2011 12:05 am

that is because of an addon youa re running is adding more info to the item tooltips and roster does not know how to parse it.. ial work on a workarround to ignore junk data
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby Obituario » Mon Feb 27, 2012 4:03 am

Hi,

I have the exact same issue, and cannot get the data to upload correctly. What did you do to solve it? I tried clicking off and on every setting and its just the same.

Thx again.

Error log just in case:
Parsing files
Parsed wowroster in 0.13 seconds
Error while parsing after 0 seconds

Processing Files
Could not find Guild. WoWRoster-GuildProfiler Addon not installed correctly?
Updating Guild Data for [El Priorato de Sion@US-Ragnaros]
Member Log
Updated: 49
Added: 0
Removed: 0
GuildInfo

Updating Members
[ Monitta ]
.
.
.
.
.
.
.
(lots of lines)
.
.
.
Updating Character Data for [Obituario@US-Ragnaros]
About to update player
Updating Equipment ..................
No Inventory Data
Updating Bank : Bag5 : Bag4 : Bag0 : Bag1 : Bag2 : Bag7 : Bag3 : Bag6
No New Mail
Updating Skills ......
Updating Professions : Jewelcrafting : Blacksmithing : First Aid : Cooking
Updating Spellbook : Frost : General : Unholy : All - Guild Perks : Blood
Updating Glyphs ..................
Updating Talents : 0-Unholy : 0-Frost : 0-Blood : 1-Unholy : 1-Frost : 1-Blood
Updating Reputation ........................................................
Updating Currency .........
Updating Quests: 7
Updating Buffs: 4
Updating Companions
Mount.......
Critter......
There was an error in addon Player Achievements in method char
Addon Messages:


InstanceKeys - Keycache cleaned - 0 gold stages activated - 0 item stages activated - 0 quest stages activated - 2 reputation stages activated - 0 skill stages activated
Obituario
WR.net Apprentice
WR.net Apprentice
 
Posts: 14
Joined: Mon Feb 27, 2012 3:59 am
Realm: Ragnaros (PvP) - Latin America

Re: Guild Vault not uploading data

Postby Ulminia » Mon Feb 27, 2012 5:04 am

what data is missing?
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Re: Guild Vault not uploading data

Postby Ulminia » Mon Feb 27, 2012 5:12 am

and a new version is aval in the dl section
Ulminia of Zangarmarsh
Zonous of Zangarmarsh
Author of Roster Gallery
WoWRoster-Profiler Redesigner
User avatar
Ulminia
WoWRoster.net Dev Team
WoWRoster.net Dev Team
Roster AddOn Dev
Roster AddOn Dev
 
Posts: 1223
Joined: Tue Jul 04, 2006 4:41 pm
Location: New Brunswick, Canada
Realm: Zangarmarsh (PvE) - US
gmail/gtalk: ulminia@gmail.com

Next

Return to General Support & Feedback

Who is online

Users browsing this forum: No registered users and 0 guests

cron