Boss progress

Joomla/Mambo integration forum

Re: Boss progress

Postby acidmax » Tue May 06, 2008 4:38 am

reznor i send u a PM
User avatar
acidmax
WR.net Apprentice
WR.net Apprentice
 
Posts: 7
Joined: Tue Apr 29, 2008 5:31 am

Boss progress

Postby reznor » Wed May 07, 2008 11:12 am

Small bugfix update!

- Bugfix: Issue with IE6 not displaying wow-style tooltip correctly
- Bugfix: Renamed class "tooltip" to "bptooltip" to avoid collisions with other css

If your wow-style tooltip isn't displayed correctly with transparency on your site, this might be the problem!
Remember: Transparency with IE only >=IE7
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Re: Boss progress

Postby Malkom » Fri May 09, 2008 3:15 pm

reznor wrote:Hello Malkom,

I tested this on my test site with boss progress on the right side with screenshots to the left with Firefox and it's working.
Then I went to your website and it's not working.
Do you use the latest version available for download?

If you want to upgrade just unzip the downloadable archive to your WEBROOT/modules directory overwriting old files.
By upgrading this way you don't have to enter everything again.


Hello reznor,

Thanks for your help.

I do an update right now, with the latest version, and it's still not working for screenshots on left :(


http://gondolyn.free.fr/index.php


EDIT :

I have solve the problem in an other way :

--- Screenshots ---
Screenshot width 480
Screenshot height 320
Screenshot distance -700

:D
Last edited by Malkom on Fri May 09, 2008 3:24 pm, edited 5 times in total.
Image
User avatar
Malkom
WR.net Journeyman
WR.net Journeyman
 
Posts: 144
Joined: Tue Jan 09, 2007 11:02 am
Location: France - 91 - Longjumeau

Re: Boss progress

Postby reznor » Fri May 09, 2008 10:18 pm

nice! :thumright:
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Re: Boss progress

Postby catgam » Sun May 11, 2008 6:13 am

I have been having a terrible time trying to get the boss progress and the latest loot mods to work... /sigh :cry:

When I click the boss progress module and try to edit the settings, it has trouble saving the settings! I have tried both using Apply and Save, but it just sends me straight back to the admin control panal. However, I have noticed that VERY rarely the apply button will then say it saved the settings, but I then have a hard time changing them again. Any ideas?
catgam
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Sat Apr 12, 2008 9:43 am

Boss progress

Postby reznor » Mon May 12, 2008 3:59 am

Sorry, catgam, no ideas!

A workaround would be to manually adjust your settings through the database table: "YOURPREFIX_modules", field to search for: mod_wow_boss_progress.
You can find every parameter in the field "params" in the same order as the admin backend.

I searched for this particular problem on acidmax' site for about three hours and I have no clue what's the reason for this strange behaviour.
So if anyone already solved this issue for himself, please make a post!
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Re: Boss progress

Postby jubilus » Fri Jun 06, 2008 9:36 pm

I received this error after installing and enabling this mod:


Warning: require(/home2/wowbunni/public_html/modules/mod_wow_boss_progress/language.php) [function.require]: failed to open stream: No such file or directory in /home2/wowbunni/public_html/modules/mod_wow_boss_progress/mod_wow_boss_progress.php on line 71

Fatal error: require() [function.require]: Failed opening required '/home2/wowbunni/public_html/modules/mod_wow_boss_progress/language.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/wowbunni/public_html/modules/mod_wow_boss_progress/mod_wow_boss_progress.php on line 71


help? :oops:
jubilus
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Fri Jun 06, 2008 9:33 pm

Re: Boss progress

Postby reznor » Sat Jun 07, 2008 12:33 am

You are on Joomla 1.5 with legacy plugin, right?
Take a look at ucof's post on page 4.

Turns out that the error was being caused by the images folder being int eh wrong place.

-modules
--mod_wow_boss_progress
---css
---images
---overlib
---languages.php

should have been
-modules
--mod_wow_boss_progress
---language.php
--css
--overlib
--images


In other words, there was an extra /mod_wow_boss_progress/ in the directory with the other files in there. They needed to be in the up one level directory.
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Boss progress

Postby cerb3ros » Tue Jun 10, 2008 6:30 pm

Hello, although the picture feature works for images be appeared on the right side of the site, when you set them to appear on the left, dont work.

Any info for this?

I saw the above post, kk :)
Last edited by cerb3ros on Tue Jun 10, 2008 7:40 pm, edited 5 times in total.
cerb3ros
WR.net Apprentice
WR.net Apprentice
 
Posts: 14
Joined: Sat Oct 13, 2007 11:31 am

Re: Boss progress

Postby ArcAiN6 » Mon Jun 16, 2008 9:49 am

Any way of getting a PHP-Nuke edition of this?
ArcAiN6
WR.net Apprentice
WR.net Apprentice
 
Posts: 11
Joined: Wed Oct 17, 2007 7:56 pm

Boss progress

Postby cerb3ros » Mon Jun 16, 2008 4:53 pm

Anyway to have on this code, also Pre-tbc Bosses?

Also, can we have different appearance order for the instances pics? I mean have the last instances we have cleared in the upper section :)

Ty :)
Last edited by cerb3ros on Mon Jun 16, 2008 4:54 pm, edited 1 time in total.
cerb3ros
WR.net Apprentice
WR.net Apprentice
 
Posts: 14
Joined: Sat Oct 13, 2007 11:31 am

Re: Boss progress

Postby Baxmor » Tue Jul 01, 2008 4:56 pm

Hi,
I'm German and I cant good English... so have please one look.
My folders are:

-modules
--mod_wow_boss_progress
---language.php
--css
--overlib
--images

But I have this problem:

Warning: require(C:\xampp\htdocs/modules/mod_wow_boss_progress/language.php) [function.require]: failed to open stream: No such file or directory in C:\xampp\htdocs\modules\mod_wow_boss_progress\mod_wow_boss_progress.php on line 71

Fatal error: require() [function.require]: Failed opening required 'C:\xampp\htdocs/modules/mod_wow_boss_progress/language.php' (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\modules\mod_wow_boss_progress\mod_wow_boss_progress.php on line 71

Can you help me please!
Baxmor
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Tue Jul 01, 2008 4:51 pm

Re: Boss progress

Postby Membrana » Thu Jul 03, 2008 11:00 pm

I cant make it work :(

It shows this.
Invalid argument supplied for foreach() in /usr/home/locura/public_html/modules/mod_wow_boss_progress/mod_wow_boss_progress.php on line 209

Here are some lines from 209:

foreach ($instances as $k1 => $v1) {

// Fetch boss links
$boss_link = $params->get( $k."_".$k1.'_link', '' );

// Fetch boss kill date
$boss_date = $params->get( $k."_".$k1.'_date', '' );

// Fetch boss screenshot
$boss_pic = $params->get( $k."_".$k1.'_pic', '' );

if ($parse_killdates==1 && $boss_date=="")
$boss_date=$date[$k][$k1];

(in_array($k1, $boss)) ? $ccolor=$color['down'] : $ccolor=$color['notdown'];
if (is_numeric($k1)) {
$progresstt[$k] .= "<tr class=\'scrlink\'>";
if ($kill_count==1 && $parse_raidnotes==1)

Can anyone help me?
Membrana
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Thu Jul 03, 2008 10:57 pm

Re: Boss progress

Postby reznor » Tue Jul 08, 2008 9:13 pm

Major update!

Upgrade:
Copy .zip file to WEBROOT/modules and unzip file overwriting old files.
You can safely remove ../modules/mod_wow_boss_progress/overlib
It is not needed anymore.

**** Changelog **** --- 08.07.08 ---

Major change:

Removed overlib to display tooltip.
The tooltip is now realized completely through CSS.
No more quoting for overlib in language.php and mod_wow_boss_progress.php needed.
No more javascript in this module.
This means less overhead (if you have itemstats installed which also uses overlib) and less code which makes it load much faster.
I commented (!) my code and it should now be more readable than before :D

New features:

- Option to change order of instance icons / names
- Option to change padding between instance icons / names
- You can now enter boss kill count manually
- Changeable font sizes / colors

- Major bugfix: Tooltips now display correctly on LEFT side from name / icon / bar
- Major bugfix: Screenshots now display correctly on LEFT side from tooltip
(High demand on that from many people)

Successfully tested with Firefox 2.0, Opera 9.5, IE7 and Safari 3.1.2 for Windows.

This version is not compatible with IE6 anymore!
And I will NEVER get back to that!
:twisted:

As always you can grab it from http://www.obscura-gilde.de

Have fun!
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

Re: Boss progress

Postby reznor » Thu Jul 10, 2008 1:49 pm

Updated again.

I uploaded a beta of this module which you can get from my page.
You can see what it does on www.obscura-gilde.de.
Now every loot and how often it dropped from the bosses is displayed.
Additionally items can be decorated with itemstats.

Be aware:
- Enabling loot might slow down page loading a little bit.
- Enabling loot and itemstats will slow down page loading, because this involves huge data loading.

Note: If you run into a "Memory exceeded" error, raise your "memory_limit" in /etc/php/apache2-php5/php.ini (or wherever php.ini resides in your installation) and (gracefully) restart your apache to apply changes.

To make itemstats get to work, you have to have puitemstats mambot installed.
This works for Joomla 1.0.x ONLY.

If somebody knows how to apply mambots to 1.5 modules, let me know and I will integrate it.
User avatar
reznor
WR.net Apprentice
WR.net Apprentice
 
Posts: 43
Joined: Fri Nov 09, 2007 6:57 pm

PreviousNext

Return to Joomla/Mambo

Who is online

Users browsing this forum: No registered users and 0 guests

cron