DF Guild Application w/ Recruitment Block

Dragonfly integration forum

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 4:16 am

Deeo wrote:Problem still exists, I cant update the Recruitment Settings.

I haven't looked at the 2.3 files yet but the previous versions of Recruitment_Settings did not have a cpg-inst.php file so there is nothing to update in the database, just update the php scripts. So unless some sort of db install file was added to Recruitment_Settings there shouldn't be an option to update.

When you click upgrade, you are making changes to the database.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

DF Guild Application w/ Recruitment Block

Postby gyrantol » Thu Jun 21, 2007 4:17 am

ok sorry was getting confused
Image
gyrantol
WR.net Apprentice
WR.net Apprentice
 
Posts: 52
Joined: Sat Apr 14, 2007 9:55 am

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 4:18 am

Razac wrote:Robo you havnt upgraded it yet have you??

Im looking at your Balck Templars and im not seeing an upgrade.

Anyway you can so I can work out anymor eissues.

I find it odd. this works Flawlessly on my machine. :)


Double post but, I haven't upgraded yet. I explained 2 posts previously why.. I am not experiencing any issues with 2.2 but if issues pop up in 2.3 I will let you know.
Last edited by robojerk on Thu Jun 21, 2007 4:19 am, edited 1 time in total.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 4:23 am

I feel like a spammer all of a sudden. =)

Deeo wrote:I cant update the Recruitment Settings.


I just re-read this.

Are you trying to upgrade the module, or are you trying to update the settings?

If you are unable to update the settings it should gave an error or exhibit some type of behavior. If trying to upgrade the module please reread my previous post.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: DF Guild Application w/ Recruitment Block

Postby Deeo » Thu Jun 21, 2007 4:31 am

Razac wrote:what new boxes???

You have roster installed you wont see any new input areas in Recruitment settings.. they will only appear if Roster is not found..


do you meant me? (sorry, for bad spelling)

i dont have new boxes oO. the block issues are mentioned to upgrading roster itself ^^.

Upgrading works fine (First i thought, that the Update didnt worked because i didnt have upgraded the Module).

here is no problem with the input of Recruitment Settings, its just that changes are not saved to the database.

--> theres no error it just saves the old data, dont know why...
Last edited by Deeo on Thu Jun 21, 2007 4:34 am, edited 1 time in total.
Deeo
WR.net Journeyman
WR.net Journeyman
 
Posts: 80
Joined: Mon Jul 10, 2006 2:02 pm

DF Guild Application w/ Recruitment Block

Postby gyrantol » Thu Jun 21, 2007 4:57 am

no Razac was talking to me when he was on about the boxes I said I couldn't find any it was because as Razac said it must have found the roster :)
Last edited by gyrantol on Thu Jun 21, 2007 4:58 am, edited 1 time in total.
Image
gyrantol
WR.net Apprentice
WR.net Apprentice
 
Posts: 52
Joined: Sat Apr 14, 2007 9:55 am

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 5:43 am

Foxpur pointed out a small issue to me. If your Application module looks like the image below please grab these fixed files.

The issue is we're using <? and not <?php

I suggest we not use <? and use <?php to avoid compatibility issues like this.
Attachments
recruitment_module_v2.3_736_fixed.zip
(137.63 KiB) Downloaded 87 times
Last edited by robojerk on Thu Jun 21, 2007 5:52 am, edited 4 times in total.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 6:05 am

From my WAMP test site.

I have full debugging enabled.

admin.php
Attachments
Last edited by robojerk on Thu Jun 21, 2007 6:06 am, edited 1 time in total.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Re: DF Guild Application w/ Recruitment Block

Postby robojerk » Thu Jun 21, 2007 9:31 am

I have my WoWRosterDF renamed to just Roster and got some nasty errors.

On /ForumsPro.html
While executing query "SELECT guild_name, server FROM cms_recruitment"

the following error occured: Unknown column 'guild_name' in 'field list'

In: /html_path/modules/Application/appconfig.php on line: 32


I fixed it but the part that checks to see if wowrosterdf is installed seems a little broken.
Image
For the Horde!
Image
User avatar
robojerk
WR.net Master
WR.net Master
 
Posts: 484
Joined: Wed Jul 05, 2006 12:17 am
Location: -The OmniMatrix- Web 3.0

Minor suggestion

Postby foxpur » Thu Jun 21, 2007 2:13 pm

Minor suggestion:

In the Application_settings (and yes, I can copy and paste it myself) where you get to select what class is wated and how badly, might want to add some minor documentation (or I can whip up so overlib.js help menus for you if you like) that contain
"High: Urgent need to recruit 1 or more. Raid-impacting.
Medium: Attendance is tight and while not impacting raids, 1 more would ease scheduling issues.
Low: Class is full but we could use a standby (in or out of guild).
Closed: Class is full and there is 1 or more standby every raid night."

and perhaps other useful help data that relates to information setting.

Also, in settings, choose of US or EU servers so that the list in the timezone-dropbox relates to what side of the planet you are on.

Fox
Last edited by foxpur on Thu Jun 21, 2007 2:27 pm, edited 1 time in total.
User avatar
foxpur
WR.net Apprentice
WR.net Apprentice
 
Posts: 49
Joined: Wed Jul 26, 2006 8:18 pm

Re: Minor suggestion 2.0 (and a problem)

Postby foxpur » Thu Jun 21, 2007 2:54 pm

On the actual application for a player submitting their data to create an application the security code is no longer displaying so the application can't be submitted (doesn't matter if user is logged in or not).

If user logged in: On failue of sumbitted application (in this case because no one can fill in the security code) the application reloads to default for 'Char name' back to the current logged in username.

Sugesstion:

On the application itself is a checkbox for "I have read and understand the FaQs" and also the box for "Link to your profile on WoW Armory: : " both have links in them to go to the related areas, however, depending on the theme those links may not show up as visible links. Eitehr make the links a separate entity of define the links somehow to display them differently to ensure the users of the site realize they are links.

Fox
Last edited by foxpur on Thu Jun 21, 2007 3:02 pm, edited 3 times in total.
User avatar
foxpur
WR.net Apprentice
WR.net Apprentice
 
Posts: 49
Joined: Wed Jul 26, 2006 8:18 pm

Re: Minor suggestion 2.0 (and a problem)

Postby foxpur » Thu Jun 21, 2007 8:10 pm

foxpur wrote:On the actual application for a player submitting their data to create an application the security code is no longer displaying so the application can't be submitted (doesn't matter if user is logged in or not).

If user logged in: On failue of sumbitted application (in this case because no one can fill in the security code) the application reloads to default for 'Char name' back to the current logged in username.


Ok, part 1 of that turns out to be my latest build of PHP when I forgot to enable GD extension. However, you should also check to make sure that GD is enabled or fail the install.

Part 2 of that is still valid.
User avatar
foxpur
WR.net Apprentice
WR.net Apprentice
 
Posts: 49
Joined: Wed Jul 26, 2006 8:18 pm

Bug report?

Postby foxpur » Thu Jun 21, 2007 8:23 pm

As a unregister user I applied to the guild and it said it was submitted to the user but there was a database error:

Code: Select all
On /index.php?name=Application&file=confirm
While executing query "INSERT INTO cms_recruit_data (Name, email, age, time_zone, charname, class, lvl, talentname, tpoint1, tpoint2, tpoint3, prof1, prof1_lvl, prof2,
prof2_lvl, fa_lvl, fish_lvl, cook_lvl, res_fr, res_shad, res_arc, res_nature, res_frost, att_ony, att_mc, att_bwl, att_naxx, att_kara, att_serp, att_eye, att_hyjal, gear_url, alt1, alt2, guild1, guild2, guild3, guild_reason, respec, scale_play, flymount, raid_mon, raid_tues, raid_wed, raid_thurs, raid_fri, raid_sat, raid_sun, bosses_zul, bosses_mc, bosses_bwl, bosses_aq40, bosses_naxx, bosses_kara, bosses_mag, bosses_gruul, bosses_serp, bosses_eye, bosses_bltemple, bosses_hyjal, tbc_key_shatter, tbc_key_shadow, tbc_key_arc, tbc_hfc_rep, tbc_cfr_rep, tbc_auch_rep, tbc_tk_rep, tbc_cot_rep, read_faqs, other_notes, cdate)
VALUES ('Fox Test', 'antonfoxworth@hotmail.com', '4', '5', 'Adella', '2', '21', 'Marksmanship', '1', '11', '0', '8', '167', '6',
'105', '97', '1','65', '0', '0', '0', '0', '0', 'No', 'No', 'No', 'No', 'No', 'No', 'No', 'No', 'http://armory.wow-europe.com/#character-sheet.xml?r=Aggramar&n=Adella', 'Tewesq', 'Destry', '', '', '', 'I have never been in other guilds', 'No', '3', 'No', '', 'Yes', 'Yes', 'Yes', 'Yes', '', 'Yes', '', '', '', '', '', '', '', '', '', '', '', '', 'No', 'No', 'No', 'No', 'No', 'No', 'No', 'No', '1', 'This is a test application', '2007-06-21')"

the following error occured: Data truncated for column 'raid_mon' at row 1

In: C:\www\sb2\modules\Application\confirm.php on line: 320

Guest information:
User id: 1
Username: Anonymous
Admin: No


I will try that again as a registered user. - nope, same error
Last edited by foxpur on Thu Jun 21, 2007 8:26 pm, edited 2 times in total.
User avatar
foxpur
WR.net Apprentice
WR.net Apprentice
 
Posts: 49
Joined: Wed Jul 26, 2006 8:18 pm

DF Guild Application w/ Recruitment Block

Postby hrisno » Thu Jun 21, 2007 9:09 pm

this is a great application and been following it. Even I wont use it for Wow I need it for LotRO.

so my question is, is there an easy way to change all the info so it fit for LotRO ?

Not that good at this yet :)
hrisno
WR.net Apprentice
WR.net Apprentice
 
Posts: 1
Joined: Sat Jun 16, 2007 12:51 am

Re: DF Guild Application w/ Recruitment Block

Postby foxpur » Thu Jun 21, 2007 9:51 pm

hrisno wrote:this is a great application and been following it. Even I wont use it for Wow I need it for LotRO.

so my question is, is there an easy way to change all the info so it fit for LotRO ?

Not that good at this yet :)


Urrr... easy answer - no.

It's all very full of checks and validations based on WoW so you would pretty much have to create a whole new form and design fro LotRO.
User avatar
foxpur
WR.net Apprentice
WR.net Apprentice
 
Posts: 49
Joined: Wed Jul 26, 2006 8:18 pm

PreviousNext

Return to Dragonfly

Who is online

Users browsing this forum: No registered users and 1 guest

cron